短线吧二维码

首页 > 股票公式 > 超准确的MACD指标

超准确的MACD指标

资料语言:简体中文

资料类别:股票公式

资料大小:6.89 KB

更新时间:2020-03-29 14:33:38

相关内容:macd金叉 macd死叉 金钻指标

  • 软件介绍

  • 网友评论
  • 下载地址


指标说明


MACD不论是做中线长线还是短线的股友,从入股市大门的那天起,都知道这个指标,在实战中,我们发现MACD顶背离后可能还会有背离,底背离后还会有背离,其实任何一种股票指标都是不准确的,只是我们把握市场趋势的一种工具,对于MACD来说,依然能够把握大的趋势方向,而且MACD的多重顶底背离的准确性还是比较高的,今天找到一个神奇的MACD指标,分享给大家,其中一个指标完全加密,没有代码可以分享,下面那个彩色MACD能提示顶底背离和金叉死叉,对于新手来说非常的有帮助,推荐给大家!具体见截图!


指标截图


超准确的MACD指标


超准确的MACD指标


指标源码


0,COLORBLUE;

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

STICKLINE(MACD>=0,MACD,0,1,1),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,1,1),COLORWHITE;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00AAFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00BBFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00CCFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00DDFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00EEFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00FFFF;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0000AA;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0011BB;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0022CC;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0033DD;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0044EE;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0055FF;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORAA00BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORBB11BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORCC22BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORDD33BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLOREE44BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFF55BB;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFAA00;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFBB11;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFCC22;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFDD33;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFEE44;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFFF55;

IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;

IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;

IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;

DRAWICON(CROSS(DIFF,DEA),DIFF,1);

DRAWICON(CROSS(DEA,DIFF),DEA,2);

{背离}

{MACD日线二次金叉}

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(二次金叉,DEA*1.25,'零下二金'),COLORWHITE;

{MACD日线底背离}

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

DRAWTEXT(底背离,DIFF*0.5,'底背'),COLORRED;

{日底背画线:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,DOTLINE;}

{MACD日线顶背离}

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(顶背离,DIFF*1.12,'顶背'),COLORGREEN;

{日顶背画线:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,DOTLINE;}

{MACD_KDJ的金叉共振}

{DIF:EMA(CLOSE,12)-EMA(CLOSE,26);DEA:EMA(DIF,9);}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));

K:=SMA(RSV,9,3),NODRAW;

D:=SMA(K,9,3),NODRAW;

J:=3*K-2*D,NODRAW;

M&K金共:=CROSS(DIFF,DEA) AND CROSS(K,D) AND CROSS(J,D);

DRAWTEXT(M&K金共,DEA*1.12,'金叉共振'),COLORYELLOW;

{MACD柱背离}

MACD高:=HHV(MACD,5);

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS(DEA,DIFF) ;

DRAWTEXT(E>0,DEA,'柱顶背'),COLORCYAN;

F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIFF,DEA);

DRAWTEXT(F>0,DEA*(-0.5),'柱底背'),COLORLIRED;

{MACD积背离}

JC:= DEA-DIFF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIFF,DEA)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

底背驰:= IF (CROSS(DIFF,DEA),REF(Y1,1),0);

DRAWTEXT(底背驰,DEA*0.8,'积底背'),COLORFF80FF;

X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIFF)),0);

前次红柱面积:=REF(红柱面积,X2+1);

前次最高价:=REF(本次最高价,X2+1);

Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);

RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

顶背驰:= IF (CROSS(DEA,DIFF),REF(Y2,1),0);

DRAWTEXT(顶背驰,DEA*0.8,'积顶背'),COLORCYAN;


注意事项


1、如果下载后,不知道如何导入此指标,点这里查看《通达信公式导入教程》。

2、技术指标的准确率尽管极高,但并不等于100%成功。

3、本股票指标完全不包括未来函数,信号不消失。

4、不管什么样票,必须设定止损点!


相关资料

  • 超准确的MACD指标  下载地址

  • 热门标签