短线吧二维码

短线吧:最齐全的短线炒股资料站!

首页 > 股票公式 > 都叫好的MACD指标

都叫好的MACD指标

资料语言:简体中文

资料类别:股票公式

资料大小:1.56 KB

更新时间:2020-06-27 03:27:35

相关内容:macd死叉 macd金叉

  • 软件介绍

  • 网友评论
  • 下载地址

指标的名字也有意思,作者命名为MACD叫号,其实都是默认的MACD参数日期值,只不过,对于一些金叉的买卖点做了信号提醒,方便有些人确定买卖点,我们先看下指标的代码:

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4; 

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

指标都分享给短线吧的股友,大家感觉信号如果不准确,可以二次编辑优化,指标的截图如下:

都叫好的MACD指标.png

虽然显示用到未来数据,但是,不影响指标的提示,更多指标图如下:

自动划线背离的MACD指标.png

对于一些背离点,也会划线显示,方便大家复盘

都叫好的MACD指标.png

这个更加准确,macd多次背离后,股价终于出现了一个比较大的下跌。

相关资料

  • 都叫好的MACD指标  下载地址

分类导航

  • 热门标签